problem with release 1.7.3 and MT4 build 920

General discussion about the Tickstory Lite software package.

problem with release 1.7.3 and MT4 build 920

Postby lenny138 » Wed Dec 02, 2015 11:08 pm

Hi,
I updated to the latest release from 1.7.2 and the backtest is no longer running under MT4 build 920. The first time I run it, the MT4 client just quits then I restart it after which I try the backtest again and it quits again. Few more cycles later when I press Start it does nothing.. I have the license key put in and before this release I have had no issues. What do you recommend to try?
lenny138
 
Posts: 18
Joined: Fri Jun 19, 2015 2:34 am

Re: problem with release 1.7.3 and MT4 build 920

Postby tickstory » Thu Dec 03, 2015 12:37 am

Hi Lenny,

As noted in the 1.7.3 release notes, please ensure you have re-generated your exports. Unfortunately MT4 has introduced a breaking change in 920 that rejects exports that were previously generated with Tickstory (i.e it insists the "server name" match that of your broker, otherwise the terminal exits). The change also means you cannot move FXT files from one broker installation to another without this "crashing" issue occurring (just in case this is something you are doing).

A short-cut to avoid regenerating the export is to use the FXT-editor and manually edit the "server name" field to match that of your broker server name (eg. "Alpari-demo"). This option should only be used by advanced users and for those who are not familiar with the process, it is recommended that you simply re-generate the export).

Hope this resolves the issue.
tickstory
 
Posts: 3411
Joined: Sun Jan 06, 2013 12:27 am

Re: problem with release 1.7.3 and MT4 build 920

Postby lenny138 » Thu Dec 03, 2015 1:07 am

Re-generating the exports will take a long time so this is out of the question at least for me. I have 28 pairs with each going back 2 years so this will take eons. Can I go back to 1.7.2? Will this resolve the issue at least so I can continue backtesting? If you could give more details about the short-cut that would be most helpful since this seems to be the least time consuming solution. Thank you.
lenny138
 
Posts: 18
Joined: Fri Jun 19, 2015 2:34 am

Re: problem with release 1.7.3 and MT4 build 920

Postby lenny138 » Thu Dec 03, 2015 3:21 am

The latest 1.7.3 is a piece of doo-doo. First all the FXT files need to be re-exported. Instead of making a utility to change the server inside each FXT data file. But why make it easy for the client.. Second it takes a LONG time to start MT4 from the launcher.. and if you are lucky MT4 will start after 5-10 minutes 50% of the time.. the other 50% see the attached screenshot..
When starting a backtest.. go and get some coffee or even better some vodka.. because you will need it. It takes 5-10 minutes to start the backtest.. the hard drive spins and spins and spins and finally the backtest starts.. but only if you have re-exported the data. Overall I am not sure if one can even use it as it is.. if one has nerves of steel and has plenty of time to kill - maybe it can be used.
Please revert to one of the earlier versions and solve these issues. Create a little utility that will ask you for the server and go through each FXT file and change whatever needs to change to be able to launch MT4 and run a backtest. I wish I had something good to say.. but I don't with version 1.7.3. it is a pain in the rear..
Attachments
Tickstory_loading.png
lenny138
 
Posts: 18
Joined: Fri Jun 19, 2015 2:34 am

Re: problem with release 1.7.3 and MT4 build 920

Postby tickstory » Thu Dec 03, 2015 4:52 am

Hi Lenny,

Just to be clear, v1.7.3 only introduces changes to address some "new" behaviour in Build 920 - the only changes we have made are listed here: http://tickstory.com/articles/tickstory ... -released/ - you will note there is no additional functionality aside from Build 920 support. We cannot anticipate changes that MT4 are going to be make and merely try to respond/adapt as soon as possible to these changes so users can continue back-testing. We unfortunately cannot spend weeks to develop and test (not to mention support) utilities that save literally a few key-strokes.

The instructions to edit your existing FXT files are as follows:

1) In Metatrader, go to File->Login and copy the text in your "Server" field (it is case-sensitive).
2) In Tickstory, go to Tools->FXT Editor and for every FXT file:
a) Open the FXT file.
b) Paste your server-name (exactly as you copied it in Step 1) in the "Server name" field.
c) Save the FXT file.

Regarding the time-lag to back-test, Tickstory does not perform any back-tests so whatever changes you have noted are presumably a result of recent changes with Build 920. I would suggest you revert back to Build 910 or perhaps mention this on the MQL forums to see if it's likely a future version will address the issue.

As for the launcher issue, we will have a look into this to see if we can provide a suitable solution. This problem usually occurs if your Metatrader terminal takes some time to load and Tickstory no longer waits. In this case, pressing the 'Launch' button again once the terminal has started easily resolves the issue.

Regards.
tickstory
 
Posts: 3411
Joined: Sun Jan 06, 2013 12:27 am

Re: problem with release 1.7.3 and MT4 build 920

Postby RayShen » Thu Dec 03, 2015 1:47 pm

How to upgrade to v1.7.3?

I back-test, MT4 will crash...........

I have bought license
RayShen
 
Posts: 9
Joined: Thu Oct 01, 2015 3:39 pm

Re: problem with release 1.7.3 and MT4 build 920

Postby tickstory » Thu Dec 03, 2015 10:45 pm

Hi RayShen,

Could you please PM us with the email details you used when purchasing a license? We can't find any record of you with the email you've provided.

Thanks.
tickstory
 
Posts: 3411
Joined: Sun Jan 06, 2013 12:27 am

Re: problem with release 1.7.3 and MT4 build 920

Postby netprofit » Sun Dec 06, 2015 7:04 pm

Hi,
for me the new update is also very annoying.
When starting a back test the Mt4 is directly crashing.
I tried everything, installed 1.72 and tried to set back MT4 to 910, but MT4 always was updating.
I deleted all my fxt history files and downloaded new, but nothing helped.

PLEASE TICKSTORY SOLVE THIS PROBLEM AS SOON AS POSSIBLE..!!!!

After long search i got it now running:
I uninstalled tickstory completely and reinstalled 1.72.
MT4 920 i have set back to 910 with this workaround:

http://ovo.cz/how-to-downgrade-mt4-920-to-910/

But this doesn't work completely, because our MT4 ist started with the launcher and not like normal and so the described "/skipupdate" doesn't work and the MT4 updates again to 920.... :x
You have to put in the "/skipupdate" into the MT4 settings in the command line of the "launcher":
https://gyazo.com/74e6eafa1daf064d0b2e60f0a372f828

If you have done all correctly you have now running again a tickstory 1.72 with a MT4 910 version.

Hope this helps other desperate users...)
netprofit
 
Posts: 26
Joined: Sun Dec 06, 2015 6:47 pm

Re: problem with release 1.7.3 and MT4 build 920

Postby tickstory » Sun Dec 06, 2015 11:01 pm

Hi Netprofit,

At this stage, the only way forward we know is to revert back to 910 if you are having crashing issues.

Thanks for the information you provided. As you mentioned, Tickstory already supports launching MT4 with command-line parameters. As shown in the screenshot, put "/skipupdate" (without the quotes) in File->Settings->MT4 Settings->Command-line parameters.
We will obviously update users if we know any other way to work around the issues with Build 920.

You can download Build 910 here:



Thanks.

skipupdatesettings.jpg
tickstory
 
Posts: 3411
Joined: Sun Jan 06, 2013 12:27 am

Re: problem with release 1.7.3 and MT4 build 920

Postby traderjoe » Mon Dec 07, 2015 2:51 pm

Hi,

I have the same problem. MT4 shuts down as soon as I start a backtest. I tried the "skipupdate" in the MT4 launcher command line but that doesn't help.

Please solve this ASAP.
traderjoe
 
Posts: 6
Joined: Fri Nov 15, 2013 5:29 am

Next

Return to General Discussion

Who is online

Users browsing this forum: Google [Bot] and 11 guests

cron